PDA

View Full Version : 5sfe timing belt cover



MCcelica
08-09-2007, 08:57 PM
How the hell do you get it off? I've pulled out every bolt I can see and a bunch that I can't see! It seems like the PS engine mount bracket is holding it on so I took out all those bolts and still can't get that to move. I need to get that off so I can get the cam gear off so I can get my inlet cam off so I can gain access to the head bolts. :madfawk: Throw me a bone here A.S.A.P plz! Thanks.

extremeskillz
08-09-2007, 09:03 PM
Is you car on jacks? The engine will need to be supported and you will have to remove the engine mount to remove the timing cover.

MCcelica
08-09-2007, 09:06 PM
Already did that. It's the bracket only that I have still on there and can't get it to move even though it has no bolts on it.

extremeskillz
08-09-2007, 09:09 PM
hmmm. try (gently) prying it with a flat head screw driver.

MCcelica
08-09-2007, 09:21 PM
Lol. Did that too. And I tried not so gently doing it. And I tried just haulin on it and I also tried getting trickey with it and tricking it into coming off. No dice. Any other ideas?

extremeskillz
08-09-2007, 09:27 PM
Hmm, sorry thats all i had. Can you drop the engine down a little to see if the cover is clear of bolts and stuff. The only other thing is to remove the mount from the engine to see it it frees it up. good luck.

MCcelica
08-09-2007, 09:32 PM
Well, yeah, there's no bolts left except for on the second (lower) belt cover. And yeah, I also tried to take the bracket off of the engine itself too. Got all the bolts out of that and it won't even fricken budge. Guess I'll just go and beat the crap out of it for a while. Sure wish I had a sledge hammer right now.

balagast
08-09-2007, 09:50 PM
can you take a pic of it ... i have taken that cover off like a dozen time now, and I always had plenty of room once the engine mount was removed. will the cover budge at all? usually once you get the 5? bolts out you can at the very least wiggle it and move it a bit.

MCcelica
08-09-2007, 10:13 PM
I don't have a camera with me but the way it sits now is it will open at the top enough get the timing belt to peak through. I already have the timing belt off of the cam gear so it will actually stick from the cover. It just won't open wide enough at the top to get a ratchet in there to get the cam gear bolt out. The socket needs about a quarter inch more clearance to get onto the bolt. So it opens up on the top pretty wide but something underneath (I'm guessing the engine mount bracket) is holding it on down there. I can wiggle it around about a half inch and the whole thing moves. I just can't get it to come off.

MCcelica
08-09-2007, 11:12 PM
Well I got the cover off. Only thing is now when I put it all back together I'm gonna need a new one. Basically I just got pissed and took a hammer to it. Since then I got the cam gear off and a couple other things off but that inlet cam still won't come out. It wiggles around on the driver side and whatnot just not enough to slip out. Lookin around I think it just needs some patient persuasion. Any ideas on that? I'll bring my camera next time I come up to work on it.