PDA

View Full Version : Stumped about no spark.



Dave9284
08-05-2007, 08:48 AM
The cars a 92 GT so of course 5sfe. Most of the time especially since temps are in the 90's when the car is at normal operating temp and I go to restart the car I get no spark. If the car cools it starts up no problem. Wierd thing is if the engines cranking and I let off the key quickly and go to start it again it most times will start up. So far I used and ohm meter to check the wiring between the ECU and igniter and distributor and it checks out. I put in a brand new distributor, coil, cap, rotor, plugs and wires. I tried 5 different known working igniters. I tried another ECU, but I'm not sure if that ones 100%. I'm lost on this I've swapped out the whole ignition system. Once the car starts it runs great, no matter what the temp it doesn't stall or misfire. Is there a relay or a ground somewhere I should look at? The ECU's ground is good along with the general engine grounds. Does the igniter ground through its mount? If so could that possibly be an issue? Thanks for any help. :Ban1:

angryyoungnpoor
08-05-2007, 07:59 PM
How are you engine grounds? Do anything with the battery? Check all your fuses in your fuse box?

I'm also currently unable to start my car.. The only things I have changed are the battery(into the trunk), a cap and a rotor. I'm thinking there is a bad engine ground that's not allowing a good spark.

PhillyDRFT
08-06-2007, 12:38 AM
I'm with AYNP on a faulty ground somewhere.

aside from that how old is your battery? I know it's a dumb thing to check but heat discharges batteries and cold tends to keep them more stable. Ever known people who keep batteries in the fridge? I would swap the bat with a new one and see if you're situation resolves. Just saying that if it's an older battery it could be on the Virge of giving up the ghost.

celicaGT90_05
08-06-2007, 12:46 AM
well heat expands things, it could be a loose wire somewhere that when its heated up it seperates and doesnt allow the full connection. What gets me is the car runs til you shut it off so I'm not so sure I'd suspect a line or ground. Does the motor crank but just no spark?

Dave9284
08-06-2007, 08:26 AM
Battery is about 1 month old. Along with new clamps and cables. The car has done this since last summer. It stopped over the winter from what I could tell, but it's mostly stored in my garage when it snows. When it won't start the starter cranks all day but won't start unless I do the little trick of letting off the key and turn it back to start real quick and it normally will fire up. All my grounds seem good I actually just upgraded all of them. I forgot to mention I did check the ECU for codes mutiple times and it was giving code 14 for lack of RPM signal from igniter. I used an ohm meter and checked for continuity between the IGF and IGT wires of the igniter and ECU. Then did the same for the G+, G-, Ne+, and Ne- between distributor and ECU and everything checked out. If I clear the codes and the car starts the code is gone. So I'm stumped there. I've tried multiple igniters and same issue. Does the igniter ground itself through its body or does it have an actually ground wire? A couple of people have suggested the ignition switch. My guess with that is maybe the switch is not always supplying voltage to ignition 2 when the switch is in the cranking position. Could the ignition switch cause this problem? Like I said before when it starts it runs perfect and doesn't stall. I even drove it 250 miles one way just last week without an issue. So it's more of an annoyance than a reliability issue, but it's driving me crazy. Thanks.

Shadowlife25
08-06-2007, 09:58 AM
I'd check the ignition switch

MR2Guru
08-07-2007, 12:27 AM
Intake manifold ground.. its a booger. I missed it when I first put the MR2 back together. Though I had really goofed something up. Turned out to be that ground from the intake manifold. Unfortunately, its much easier to get to on the MR2.....

MR2Guru
08-07-2007, 12:28 AM
Does the igniter ground through its mount? If so could that possibly be an issue?

Yes, bolt this down first. If there is still no dice, try my suggestion in the last post.

zen
08-08-2007, 06:21 PM
i had the same problem with my celica. It turned out to be a loose relay. Unplug the EFI relay and plug it back in.

90'BlackGTS
08-09-2007, 04:05 AM
Yup this is a common problem on Honda's also of the same years. More then likely its the main relay needs to be replaced or you can usually fix then yourself by soldering them. CHeck that, i bet thats the problem

angryyoungnpoor
08-09-2007, 04:55 AM
Where is the intake manifold ground? I think this may be a problem of mine. The o2 sensor, ecu, and a bunch of other things are grounded to that, but.. I don't know what it's grounded at. I think there might be something wrong with my EB ground or.. "the one on the right fender," which is why i have no spark.