PDA

View Full Version : Battery light on



Colossus20v
02-10-2005, 10:49 PM
Hey guys,
My battery light was flickering a little bit but now stays on. I turned the car off then turned it back on. It has been stutering a little before it actually starts but it has been like that since i brought it home. Any ideas? Do I just need a new battery or should I just charge it back up?

Thanx for the help.

Dr.Auto
02-10-2005, 11:08 PM
Your alternator brushes are probibly worn out. Your brake light probibly turns on too because it's on the same circuit. You can either put new brushes in the alternator (about $20 in parts) or a new alternator. I would also have the battery charged then tested.

Blackcloud
02-10-2005, 11:45 PM
Alt is going out..

and im with doc.. have your battery checked while your at it too

Colossus20v
02-10-2005, 11:46 PM
if my alternator stops working while im driving what will happen. I am at school now and have about 10 -15 miles to drive home.

Punisher
02-10-2005, 11:48 PM
Well.. um.. your battery will begin to run your car.. who knows how long it'll stay running until you drain the battery and then it'll stall and it won't start back up.

Colossus20v
02-11-2005, 12:03 AM
damnit....wish me luck guys...

corvelx
02-11-2005, 12:26 AM
Just don't run the stereo or heat/ac and etc. to conserve on battery life.

I'm going to bet that 10-15 miles will be fine.

Colossus20v
02-11-2005, 12:35 AM
ill just prepare for the power steering to fail if it stalls. Ill be fine Im sure but it still pisses me off.

locker
02-11-2005, 01:01 AM
make sure to keep your rev's up! My car died two weeks ago with the same problem. When your coming to a stop drop the car into neutral and keep your rev's around 2grand and it shouldn't stall out. I was slacking and let my rev's fall below a grand and that was all she wrote until the two truck driver arrived!

Colossus20v
02-11-2005, 01:17 AM
i wont have any problem keeping the revs up buddy :D :hehe: :wink: The 20valve loves to breathe. Its such a rev happy motor.

mikeswickednick
02-11-2005, 02:14 AM
i drove my mr2 on just the battery and i went about 50mins on it and i could have gone longer

Punisher
02-11-2005, 09:37 PM
if you don't have lights or anything on you can go longer.. simply because your engine doesn't really use much power at all for the ignition or anything.. your alt should stay at atleast 11v.. that's enough to get you there.

Luni
02-11-2005, 11:22 PM
i drove my mr2 on just the battery and i went about 50mins on it and i could have gone longer

Did it boost correctly on just the battery?