PDA

View Full Version : weeee, help with 3sgte



xeril
02-09-2005, 05:17 AM
okay, it starts up fine and everything. it even drives a bit, but it doesn't seem to like boosting much. for example, i took it up the street today, all warmed up and stuffs, just floored it in first gear, and it stalled out. i almost think its running too rich before shifts, causing it to flood the engine and stall out. at idle its showing 15-16lbs of vacuum. and in first gear it boosted to 10psi. other than that, it seems happy as a bird (hah, that analogy doesn't even make since.) but yeah.. any ideas of what the problem could be? i'm sorta thinking isv or maf. i read something about unplugging the isv and it'll run a little higher rpm? but i did that and my car just stalled out.. meh! it idles about 1400rpm (1100 with idle screw completely tight) and i notice, when revving from a stand still, the engine hit a wall at like 5000rpm, but driving it earlier when it stalled out, i believe i tried shifting at 6200rpm.. so i almost think one of the intercooler hoses could be leaking. tell me your thoughts!! thanks in advance :)

ChrisD
02-09-2005, 04:17 PM
Seems like a pretty significant air leak to me...but it's hard to say. Check that your AFM is connected properly. You might want to also check the ISC valve. Those seem to be the most likely causes without getting to take a look at it.

:)

ChrisD
02-09-2005, 04:21 PM
Actually check the ISC first. High idle + stalling is a good indication. Check the resistance between the middle pin and each of the side pins. It should be between 17.7-23.9 Ohms.

Lagos
02-09-2005, 05:53 PM
the hitting a wall feeling could be fuel cut. your vac readings are too low, so you must have a leak somewhere, or a cheap vac gauge. check your timing to make sure its at 10tdc.

are you getting and check engine codes?

xeril
02-10-2005, 05:58 AM
what is the usual vac reading at idle? i think its pretty much narrowed down to the isc, fuel pressure regulator, or massive vacuum leak. sooo, most likely a or c. stalls out when i rev it to 6k or so.. vac at around 16/17.. gonna check codes as soon as friend can do it for me at toyota (tomorrow or next day hopefully) or if i can get that wire from an auto celica for ecu :)

edit: the bgb says vacuum at idle should be 17.7 in.Hg??

Stinger
02-10-2005, 08:23 AM
My vac at idle reads 20-21ish

Supersprynt
02-10-2005, 05:27 PM
I get 18 cold, 21,22 warm.

Also checking the codes is easy, you can find the how to somewhere around here. Are you getting a CEL?

xeril
02-10-2005, 06:42 PM
its easy, but i believe you need the third ecu wire plugged in..

Supersprynt
02-10-2005, 08:37 PM
why is it out?