PDA

View Full Version : Noise from under dash?



zmile06
01-21-2007, 05:00 AM
So anyways i tore my dash apart blah blah, heat works but air flow problem blah blah.

I keep pressing the directional air flow buttons and i hear a clunk behind the dash and i get air flow properly again and the heat works a 100 times better.

Anyone have any idea what the clunk noise might be? It sounds like its coming from behind the heat controls or maybe the odomoter.

alltracman78
01-21-2007, 05:37 AM
It's the servo motors moving the flap doors inside your system around.

When you change where the airflow is supposed to go, it opens and closes the required flap doors in your system.

If the system is working slower now than when you replaced your heater core you might have knocked something loose.

The controls MIGHT also be going bad, maybe a bad contact in one or more of the switches if you have to keep pressing the controls to make it work.
Try pressing it once and seeing if it works after a couple of minutes.

Also you might not have connected something 100%.

Unfortunately something like this is hard to tell online, you have to look it over.

zmile06
01-21-2007, 06:11 AM
I have tried just leaving it for 10 miniutes at a time dosent do anything. I got air flow fine before i changed the heater core. Now i only get air flow after pressing each of the air flow buttons twice each maybe more. Then i hear something falling behind the dash and i get air flow and heat perfectly.

What do you mean the controls are going bad...? The control pannel that changes the air flow?

It moves the air flow fine, until i get to the dash air flow then i have to keep pressing the controls and coming back to that one to get it to work. But i hear a noise like something falling behind the dash before the dash airflow/heat works.

I'm just trying to narrow things down because i really dont want to take apart the whole dash again it will take me 2 days.

Amaymi
01-21-2007, 04:30 PM
i was having a similar problem in my celica. It has the push button controlls as opposed to the knobs and levers. Sometimes my heater would work and sometimes it wouldn't completely at radom. So I decided to take my center console off and unplug and remove the controll unit. Oddly enough after cleaning it off and replugging it it all the heater has worked with no problem ever since. I guess maybe you should take the controll unit out and double check your connections and such. I think my problem came up because the car had been sitting for over a year.

zmile06
01-21-2007, 09:33 PM
I have 2 knobs 1 for fan and 1 for cold/hot control. I think the wires and stuff are hooked up fine...

The real strange part i hear something moving or falling behind the dash right before it works did you have that noise?

alltracman78
01-21-2007, 10:43 PM
The real strange part i hear something moving or falling behind the dash right before it works did you have that noise?



It's the servo motors moving the flap doors inside your system around.

.

MCcelica
01-21-2007, 10:49 PM
I'm with ATman on this one. If you have the key to the "on" position and you turn the air flow and radio off, you will still be able to control which zones the airflow goes to. If you punch those buttons you can still hear a little whining coming from the servo motors changing the air flaps. I'd say either one or more of your flaps are out of place, and/or your motors could be going bad. I would say since you can hear a falling sound it'd be the flaps.

zmile06
01-22-2007, 09:02 PM
Ok so anyways someone have a picture of these flaps? Because im not sure what you guys are talking about? Could it be the gears on the side not hooked up properly causing the flaps not to switch correctly?

I wont even get hot air until i hear that noise, and it wont come out of the middle dash utnil then either.