PDA

View Full Version : help!



briscoed_st185
12-03-2006, 10:26 AM
hi there everyone
i drive a 1992 st185 and i need some help! well last nite i was driving home and ended up melting 2 spark plugs and the engine light came on. i have only just bought the car and the lad that had it before put a to hot grade plug in. anyway i have put in some colder HKS plugs and now everything runs fine but the engine light wont go off? i have run diagnostics and there is no error codes also now the LED knock sensor stays red perminently could this be because of the engine light?

any help appreciated
thankyou
dan

fujoejoe
12-03-2006, 09:08 PM
Try pull out the EFI fuse from engine bay to reset the light.

alltracman78
12-04-2006, 03:25 AM
What is the knock LED?
An aftermarket LED hooked to the knock wiring?

What do you mean you melted 2 plugs?
You actually melted them?
All, part?

Pulling the EFI fuse will erase all codes stored.
However, if you still have a problem the light will come back on.

Since you have a 92, you have a second more sensitive diagnostic mode available.

Open your diagnostic box and jump TE2 and E1.
Leaving the jumper in, drive around simulating your problem.
Or just drive around.

Once you return, remove the jumper from TE2 and E1 and jump TE1 and E1.
This will tell you if you have any problems.

alltracman78
12-04-2006, 03:27 AM
Oh, and for the record, NGK plugs are fine. Or Denso. No need to spend the extra money on HKS.
If the HKS ones are just as cheap I guess it doesn't matter. But here at least I can get the correct NGK coppers for less than $2US each.
The irridiums I can get for around $8US each.

briscoed_st185
12-04-2006, 10:58 PM
ok mate thanks alot for your help! i had it looked at today and it appares to be a rod bearing so its going in tomorrow for re-build i had the hks plugs lying around from my dads supra otherwise i would'tof bothered cheers!!

briscoed_st185
12-04-2006, 11:01 PM
oh and i part melted them just the ends burnt away!

fujoejoe
12-08-2006, 10:10 PM
sorry about my post, now that I re-read you post I didn't help at all.