PDA

View Full Version : Where did my boost go?



wanabe gt-40
11-30-2006, 05:59 AM
One day I was passing a truck with my 2nd gen 3sgte went pop and squirted a little coolant. Immediately my engine sounded different. Kinda muffled not sharp and raspy like it use to. Now I know you may be thinking head or gasket but wait. The engine starts and runs perfectly fine. Oil is crystal clear. I'm not loosing any coolant (internally). But it won't build more than like 6lbs boost without a spit from the radiator cap (new 13lb). I pinched off the wastegate hose and ran the car hard and it still would not build boost but really spit out the coolant.
Can a turbo charger develop a leak internally and loose boost into the cooling sytem through the water line that cools it?
If you were too start tearing the motor apart where would you want to start?

Rix86
11-30-2006, 06:09 AM
Head gasket.

msvasquez22
11-30-2006, 02:45 PM
You might have blew a seal in your turbo, take the downpipe off and see if you see any oil anywhere.
you might also want to get this thread moved to forced induction, alot more help is there

Gary
11-30-2006, 07:32 PM
Can a turbo charger develop a leak internally and loose boost into the cooling sytem through the water line that cools it?
No.



One day I was passing a truck with my 2nd gen 3sgte went pop and squirted a little coolant
Immediately my engine sounded different. Kinda muffled not sharp and raspy like it use to.
it won't build more than like 6lbs boost without a spit from the radiator cap

Most likely and best case scenario, blown HG.
Worst case scenario, cracked block
Depend on whrere the HG is damaged, you might not see oil in coolant or coolant in oil.

alltracman78
12-01-2006, 03:05 AM
Head gasket.

+2