PDA

View Full Version : Code 71 and altitude, o2 sensor too maybe?



ALLEN
01-20-2005, 11:35 PM
Hey guys, first post here, used to loom around c.net :ugh: and still roam around OTUG if any of you remember me.

Here it is, since maybe September I've been getting the CEL on and off sometimes for long or short periods of times, it reads as Code 71, EGR System. Only happens when I'm up here in Prescott, AZ (elevation about 5,500ft), but when I'm back home in Vegas' for breaks, never comes on. My dad and me cleaned out the EGR valves sometime last year too because one of the little hoses kept coming off at high rpm and making a 'whistling' noise.

Could it be the o2 sensor? I get good mileage still (from full tank to empty about 327 miles), but I notice a slight shudder when the car is shifting from 1st to 2nd (auto trans). I remember it went away this last summer when we changed out the old CAT, seems to be coming back..

Any ideas?

ALLEN
01-25-2005, 05:37 AM
Any one!?

BraveUlysses
01-26-2005, 09:20 PM
A bad O2 sensor will throw a code at you if it indeed is bad. If you want, go ahead and pull it out and visually inspect it for heavy deposits.

If you're getting an EGR code, pull the egr lines and valve off, throw it in a tub of simplegreen overnight, thoroughly clean it out, give it a fresh coat of spraypaint if you so desire, and put it back on. Seal up where it meets with the intake maifold using some ultra copper silicone sealant. It may take some time for it to re-seat itself.

If this still doesn't work after a while, you may need to replace your egr system or buy some block-off plates.