PDA

View Full Version : Car wont start



D Devil
01-20-2005, 10:00 PM
Ok, I go out to my car and try to turn it on, it doesnt even turn over. I have this thing where it can kickstart your battery so I hook that up to it and it just barely starts. When I removed the cables, it went crazy and the wipers started going real fast and the motor was shaking. So I just shut it off. I have one of those Optima Red Top Batteries. Im guessing its dead already? What a waste of money.

Hooligan
01-20-2005, 10:05 PM
This sounds like a classic dead battery story except the wipers going fast, etc.

It's not the battery's fault if you have a failing alternator, or left the headlights on, or...

I would try to charge the battery or get a jump before making any more conclusions.

SilverCel
01-20-2005, 10:08 PM
Don't the optima batteries have self charging capabilites?

Hooligan
01-20-2005, 10:11 PM
Don't the optima batteries have self charging capabilites?

I don't see anything about that on their site. I haven't EVER heard of a battery that can recharge itself.

Galcobar
01-20-2005, 10:37 PM
I don't think batteries come with generators, which is what would be required to self-charge...kind of redundent when you've got an engine and an alternator.

Double check that everything is off -- wipers, radio, interior lights, exterior lights, fans, etc. Those kickstart systems are designed just to get your car running, so that the engine can charge the battery.

Big thing -- make sure you're removing the cables in the correct order or you can screw up your electrical system.

Personally, I'd go with a tried and true jump start from another car, then drive down to your battery dealer and ask them to test the battery.

D Devil
01-20-2005, 10:48 PM
Yea, I did not leave anything on, never have. When I removed the cables I removed the negative first, was that the wrong one?