PDA

View Full Version : 5th gen powersteering and autocross



Nemesis3S-GTE
01-13-2005, 12:31 AM
Well, since i don't own my Subaru anymore, and I still plan to autocross this summer, I will be doing so in a 5th gen for the first time in a few years. I remember having a problem on especially tight courses where it seemed that I could turn the wheel faster than the power steering pump could supply fluid, making the wheel hard to turn. This became particularly annoying because it was harder to judge how much force to give the wheel, making my driving not as smooth as I would have liked. I was wondering if anyone else has experienced this and found a solution. A newer pump was installed in the GT since I autocrossed it last, but it doesn't seem to make much of a difference as far as I can tell. As for the All-Trac, it has basically no power steering anymore, someone before I owned it didn't fix a leak in the system and didn't keep fluid in it either, destroying the pump. The AWD does seem to make it easier to turn anyway however, so it's not as noticable.

Now, I only autocrossed the Celica during my first season mainly, then i drove the Legacy SS last year without a problem so maybe my driving skills were to blame (ie. getting into situations where i HAD to turn the wheel fast), but I still think that the equipment had something to do with it. I can't wait to get back to dodging the cones with a Celica, maybe I'll actually start to become competitive this season (not likely since the GT will throw me into SM, and the All-Trac needs a lot of suspension work if I choose to drive it)

roman
01-13-2005, 01:39 AM
I had the same problem with my '90 GT-S. The power steering would almost always cut out when I went through Chicago boxes (or garages, whatever your club calls them). I never did figure out how to solve them. One of my friends has the same problem in his Miata too (although it's the only P/S Miata I heard of with the problem). I just took my power steering out alltogether :cool:

EvilSpeeder
01-13-2005, 02:09 AM
I've had the same problem with my '94 but I also don't have a solution. Drive smoothly and don't get behind in the slalom!!!!

Luis C
01-13-2005, 02:40 AM
PS failures/leaks and Celicas (specially 5th Gens) go together like bread and butter.

I'm on my second high pressure PS hose replacement and steering box rebuild in 3 years

Nemesis3S-GTE
01-13-2005, 04:43 AM
hmmm....maybe when i finally get around to installing my extra pump into the All-Trac i'll look at the old one and see if anything can be done like swapping to a different Toyota pump for better flow. I'm sure that the pump simply can't keep up with the rack at the speeds i was turning the wheel, but we'll see how the car handles this spring. Hopefully my driving has improved and this problem won't be as noticable.