PDA

View Full Version : Heating System Problems



Grafal
12-11-2005, 01:10 AM
Hey everyone, I have a 1990 Toyota Celica GTS and it seems to be only blowing cold air through the vents. It does heat up eventually, but half the temperature it should be and even that takes like 30 mins. The air velocity coming out of the vents is still the same, just the temperature is too low. The heater core was replaced last winter because it was leaking and everything was fine after that. And the radiator was just replaced because the old one was leaking as well. Just changed the thermostat right and the problem has not been fixed. If anyone has any ideas on what could be wrong, drop me a line on here...I have already ruled out the radiator, heater core, and thermostat so help me out please.

Thank-You

Mister2T
12-11-2005, 01:27 AM
how long ago was the thermostat repllaced and perhaps you put ina bad one as well, they are cheap enough, i would go pick up another one, make sure you have the proper amount of coolent in the radiator. I would do a good flush as well, that could help out, if there is debre in there it will not circulate properly.

WannabeGT4
12-11-2005, 02:55 PM
http://www.celicatech.com/forums/showthread.php?t=12656

Mister2T
12-11-2005, 03:03 PM
If you pull back the carpet a bit near the center of the car on the passenger side under the dash you should see a metal rod going to a flap on a big white box. Make sure that when you switch from cold to hot the metal rod moves that flap. Mine broke off the flap and I lost heat as a result. Took me a year to figure it out. I ended up using some super glue to fix it but it was summer time already ;)
this quote is from another tread but something you may want to check..