PDA

View Full Version : bad oil pressure sensor



fiveSFE
12-20-2004, 12:54 AM
i noticed my moms car is leakin alot of oil, she drives an 88 jetta that is in perfect condition. it can go threw a quart in about 30 minutes, i finally got to looking at it today, and i traced it down to the oil pressure sensors. the car has 2 oil pressure sensor right above where the oil filter is, so i pulled off the sensors and put tephlon tape on the threads cuz thats where i thought it was leakin from. so i go drive it and its still leaking, could i just need new oil pressure sensors? if they are bad do they leak like that, i need to find a quick fix because my mom needsher car by tommarow, i might try to see if the threads are the same as my celica so i can put my old one on it for a quick fix and see if that works

Trance4c
12-20-2004, 01:08 AM
i noticed my moms car is leakin alot of oil, she drives an 88 jetta that is in perfect condition. it can go threw a quart in about 30 minutes, i finally got to looking at it today, and i traced it down to the oil pressure sensors. the car has 2 oil pressure sensor right above where the oil filter is, so i pulled off the sensors and put tephlon tape on the threads cuz thats where i thought it was leakin from. so i go drive it and its still leaking, could i just need new oil pressure sensors? if they are bad do they leak like that, i need to find a quick fix because my mom needsher car by tommarow, i might try to see if the threads are the same as my celica so i can put my old one on it for a quick fix and see if that works

They might be the same, as they both are probably metric based, but that doesn't garantee that this will work.

fiveSFE
12-20-2004, 01:14 AM
i justneed it to stop leaking for now,

Hooligan
12-20-2004, 03:28 AM
The goopish stuff will seal better, but it makes a mess too.

TRDmkII
12-20-2004, 04:08 AM
well a lot of times those sensors actually leak through the electrical connector, my gf's car was leaking about a qt a day just steadily dripping from the oil pressure switch

if I were you i would try and replace them...a cheap napa replacement will do.

fiveSFE
12-20-2004, 10:11 AM
yeah thats what i was thinking, it was a sunday and i had no ride down the autozone or napa, so ill try to get it done tommarow

Mister2T
12-22-2004, 02:55 PM
I had a bad one and the motha was gushin oil outta the front of it heh.

fiveSFE
12-23-2004, 02:50 AM
i found out one of the sensor is for oil temp. and the other was prssure, no one carries the temp sensor so i just got 2 oil pressur sensors for 5 dolla each and put em in there, the digital reading for the tmp is close to what it was before. the car is still leaking i think tho, once in a while i see a small drop of oil underneith it.